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July 2009

Setting Up Load Pull with X-Parameters
Using the Agilent NVNA
Introduction
This application note provides step-by-step instructions for setting up a test bench for load pull with x-parameters
measurement using two Maury MT98x Series automated tuners, Maury ATS software version 5.1 (build 5 or newer),
and the Agilent PNA-X test set, to test a low-power DUT of a type suitable for direct connection to the PNA-X.

Step 2. Characterizing The Tuners

1.1

2.1

The tuner planes should be setup so both tuners
are 3.5mm-female to 3.5mm-male.

2.2

If the tuners need to be characterized, setup the
system to go between the PNA-X ports 1 and 2,
and run the standard PNA software, not the NVNA
software. Setup a config with just the tuners, a
VNA, and RF switches, using VnaPnaxCom.exe
and SwPnaxCom.exe for the drivers.

2.3

Make sure that the connection links are all in
place on the PNA-X.

2.4

Do an in-situ cal, and uncheck both noise and
power. It will prompt to cal 2-port at the DUT
planes, 1-port after the load tuner, and 1-port
before the source tuner (if used). Then it will cal
both tuners together. Adaptive Modeling with .08
separation, 45° max phase step, and 5 harmonics with speed enhancement will take about 20
minutes per tuner.

Required Software Versions:

1.1.1		PNA-X firmware revision A.08.50.01 or later
1.1.2		NVNA firmware revison A.01.01.00 or later
1.1.3		ATS Software version 5.1.00 Build 5 or later
1.2

Boot up the PNA-X. It will start the PNA-X app
automatically.

1.3

In the PNA-X app, select File->Exit to close the
PNA-X app.

1.4

Put a memory stick with the ATS installation file into
a USB port and use the explorer to find and run it.
When the installation is complete, reboot the PNA-X.
Use the start menu to find the icon to start the ATS
software. Click and hold the right button, and drag
it to the desktop. Release the mouse, and select
copy the shortcut.

BNC-m
BNC-f

1.5

AGILENT
CALIBRATION
COMB
GENERATOR

BNC-f
BNC-m

Step 1. Software Installation

BNC-m
BNC-f
IN

3.5mm-m
3.5mm-f

10 MHZ
OUT

AGILENT NVNA

U9391C

Out

3.5mm-m

3.5mm-f
3.5mm-m

3.5mm-f

OUT

8022S

8022T

MAURY TUNER

DUT

MAURY TUNER

MT982EU30

MT982EU30

TUNER PLANES

3.5mm-f
3.5mm-m

36-IN.
GORE
CABLES

7mm
7mm
3.5mm-m
3.5mm-f

8022T

7mm
7mm
3.5mm-m
3.5mm-f
3.5mm-m
3.5mm-f
7mm
7mm

3.5mm-m

3.5mm-f
7mm
7mm

8022S

36-IN.
GORE CABLE

U9391C

OUT

3.5mm-f

Comb Generator
adaneias sas agl

Heggian

RCVR B IN

3.5mm-m
3.5mm-f
In

Out

PORT 3

IN

CAUTION
10 MHz TO 55 MHz
RFI COMB GENERATOR

Heggian

Comb Generator
adaneias sas agl

In

CAUTION
10 MHz TO 55 MHz
RFI COMB GENERATOR

PORT 1

AGILENT
POWER SENSOR
COMB
GENERATOR

TUNER PLANES
DUT PLANES

Figure 1. Setup for the Standard Demo
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Step 3. Setting Up The System
3.1

3.2

3.3

See Figure 1 for the standard demo setup. Every
link on the front panel must remain connected
except the top link on the right, which must be
removed to allow the Comb Generator to be connected to the RCVR B IN.
Use a BNC Tee on the 10 MHz reference output
(rear panel), and use 2 BNC to SMA cables to
connect the 10 MHz to the input of both Comb
Generators.
Note that both the comb generator to be used for
calibration and the power sensor have 3.5mm male
connectors, so they can both connect directly to the
DUT output reference plane (PNA-X port 3).

3.4

Set up a 12 Volt supply capable of about 1 amp.
Connect the bias cables from both Comb Generators in parallel to the 12 Volts. On the Comb
Generator bias cables:
		 Red = +12 Volts
Green = ground
		 Black = not used
3.5

RF Connections (See Figure 2 for connection diagram).

3.5.1 Remove the top link on the right side of the front
panel and connect the output of the measurement
Comb Generator to the “RCVR B IN” connector.
3.5.2 Arrange the second (Calibration) Comb Generator
so that the cables will reach the DUT port. It will
be used during the NVNA cal only.

3.5.3 Connect the PNA-X port 1 to the input of the
source tuner.
3.5.4 Connect the PNA-X port 3 to the output of the
load tuner.

* Note: If external instruments are to be controlled by
GPIB, use the top GPIB connector on the back of the
NVNA (labeled "Controller"). See Step 6 for setting
up NI-488.2 compatibility.

Step 4. Starting Up The NVNA
4.1

Boot up the PNA-X. It will start the PNA-X app
automatically.

4.2

In the PNA-X app, select File->Exit to close the
PNA-X app.

4.3

Click on the NVNA icon on the desktop to start it up.

4.4

Setup the 10 MHz reference signal as the Comb
Generator source.

4.4.1 In the NVNA app, select Utilities->External
Instruments->Phase Reference->Source Setup (see
figure 2).
4.4.2 In the top drop-down box, select 10 MHz.
4.4.3 Select Divide ratio to be 1.
4.5

For this demo, we will only make measurements
using the General Domain without envelop domain, doing CW measurements.

4.6

Turn off leveling, if desired.

4.7

Turn on high power mode, if desired.

Figure 2. Connection Diagram and Setup Using the 10 MHz Source to Drive the Comb Generators.
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Step 5. Setting Up The Bias
5.1

The ATS software should control and set the bias, and
also read back the bias to get PAE into the ATS data.

5.2

When taking x-parameter measurements, the NVNA
should also read the bias, so that PAE is modeled
correctly in the x-parameter file. To set this up:

5.2.1 From the NVNA menu, select Utility->External
Instruments->GPIB Instrument Control.
5.2.2 Click on the “Add Instrument” button.
5.2.3 In the list of Instrument Properties, highlight a
property one at a time to enter the data for that
property. The main properties to setup for reading
bias are usually:
		

a) Name

		

b) GPIB Address

		

c) Measured Variables – typically I2 for output current. Could also add I1 for input current, V2 for
output voltage, or V1 for input voltage. Typically
input bias variables are not needed because
they don’t change or are not significant.

		

d) Measurement Commands – need all commands to measure I2 on one line. If additional
measured variables are to be used, use one
line for each.

		

e) Timeout – this is entered in mSec.

5.2.4 Do not include the following, as doing so will
interfere with the ATS settings:
		
		

a) Initialization Commands
b) Outer Loop Commands

		

c) Sweep Variables

Step 6. Setting Up NI-488.2 Compatibility
6.1

Required to run ATS GPIB drivers.

6.2

Run the Agilent connection expert.

6.2.1 Run it from the computer start menu->Agilent IO
Libraries Suite.
6.2.2 Select Tools->Agilent 488…:
		

“GPIB Board button. Enable the GPIB and set the
address of the GPIB board.

Step 7. Calibrating
7.1

7.1.1 Start the ATS software by clicking on the ATS icon
on the desktop.
7.1.2 Select nvna.cfg as the starting configuration. Change
the tuner model and serial number as required.
7.1.3 At least initialize the tuners and set them to Z0
before calibrating the NVNA
7.2

		

a) From the popup menu, select “Change Properties”.

		

b) Click the “Agilent 488 Properties…” button,
and note the GPIB board number. This is the
address of the GPIB board to use in the ATS
software (NVNA default is 10).

6.2.4 In the ATS software, select “Setup Instruments“
from the main block diagram menu, and click the
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To calibrate the the NVNA:

7.2.1 In the NVNA app, select Utilities->FW Visible.
This is an optional step that will start up the normal PNA-X firmware and make it visible. There
is a delay while it starts, but once started, the cal
wizard will go more quickly.
* Note: Press the Alt-Tab keys together to switch back and
forth between the NVNA app and the ATS software.
7.2.2 In the NVNA “Measurement Configuration/Calibration” tab, enter the start and stop frequency to
be the same as the fundamental frequency that
you want to measure, and click “Apply”. This will
make the calibrate menu item available.
7.2.3 In the NVNA app, select Response->Cal-> Calibrate. This will start the calibration wizard.
		

a) Vector cal (click on the red button) – this will
start the calibration wizard from the normal
PNA software. There may be a significant
delay until the PNA software loads for the first
time. Do a 2-port cal between ports 1 and 3.

		

b) Phase cal – Connect a comb generator to port
1 or 3 at the DUT plane (In my setup, port 3
is used because the test port is a female connector.) Be sure to select the correct comb
generator.

		

c) Power Cal – Connect the power sensor to
the same DUT plane as the phase cal. In my
setup, that would again be port 3.

7.3

Prepare the ATS software for measurement with
the NVNA.

a) Check Enable Agilent GPIB cards for 488 programs

6.2.3 Right-click on “GPIB0” to get the popup menu:

Initialize the tuners and set them to the Z0 position.

7.3.1 In the ATS software, double-click on the LSNA
icon to bring up the properties dialog. Then
select the LSNA Calibration Reference planes to
specify where the NVNA cal planes are:
		

a) DUT: means that the NVNA cal planes were
exactly the same as the DUT planes.
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b) Tuner: means that the NVNA cal planes are
next to the tuner, on the side of the test fixture
away from the DUT. If there is no fixture
specified in the block diagram, the DUT
planes and the Tuner planes are identical.

Calibrate for power in the ATS software

7.4.1 In the ATS software, select Setup->Options,
power tab, make sure that:
		

a) the Power Measuring Instrument is the LSNA.

		

b) Interpolated Tuning is checked (required to
export x-parameters to ADS)

		

c) The gamma-state Separation is reasonable (~0.2).

7.4.2 Run the CW power cal.
7.5

		

c) Test Port: means the NVNA cal planes are on the
back side of the tuner, away from the DUT. This
may be required if the power sensor and comb
generator used for the NVNA cal cannot be connected to the DUT or Tuner planes (e.g., when
making on-wafer measurements).

7.3.2 Measure the load termination behind the load tuner. In the ATS software, select Calibrate->LSNA->
Load Termination. Enter a label and filename, and
an .s1p file will be saved. Then to use the file, select Setup->Options->Power tab, and set the Load
Gamma Calibration to .s1p file. Select Setup->
Default Files/Directories->Power tab, and enter
the filename for the Power Load Gamma.
7.4

7.5.5 A sweep plan can sweep frequency, input power,
and bias.

Measuring with X-Parameters in the ATS Software.

7.5.1 In the ATS software, select Measure->CW to enter the interactive measurement screen.
7.5.2 Select Setup->Options and Configuration…, and
in the tuning box of the power tab, set interpolated tuning to Yes, and enter a suitable GammaState Separation, such as 0.2. This is important,
so that you can select a uniform grid of gamma
points, as required by ADS. Note that the PHD
model in ADS is said to be valid for roughly 2:1
vswr around each measured point.
7.5.3 Select Setup->Select Measurement Parameters…,
and double-click on X-Params to select them.
7.5.4 Clear any previously selected gamma points.
Then right click on the load chart, and Select
points Density. Then drag the mouse over the
desired portion of the Smith chart. With interpolation set to yes, this should give a uniform grid
of gamma points.
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a) If frequency is a variable, all frequencies must
be on the same regular grid. To set this up,
select the gamma points on a regular grid at
one freq, then in the sweep plan setup dialog,
click on details for the gamma variables. In
the gamma details dialog, click the button
“Select these gammas for all frequencies”

		 1) * Note: this is required for ADS to interpolate between freqs.
		 2) If the desired gamma needs to rotate much
on the Smith chart vs freq, select a range
covering all desired freqs. Then to save time,
un-select portions of the Smith chart that are
not needed at each freq. The data should then
be valid in ADS at each freq, but interpolation between freqs may not work.
7.5.6 Run a measurement. If X-Parameters were selected for measurement, then when the normal ATS
file is saved, two additional files will be saved.
If Filename is the file name for the normal ATS
data, the extra files will use names derived from
it as follows:
		

a) Select a Filename with no spaces, otherwise
ADS will not accept it.

		

b) Select a Filename starting with alpha character, otherwise ADS will not accept it.

		

c) Filename_PHD.mdf – this file contains the
normalized x-parameters that are used in the
PHD model in ADS.

		

d) Filename_XP.mdf – this file contains the unnormalized x-parameters.

7.6

Loading the X-Parameters into ADS for simulation

7.6.1 Copy or move the Filename_PHD.mdf file into
the ADS project directory. Typically this will be
C:\users\default\PHD_Demo_prj\PHD_Files.
7.6.2 Run ADS, and install the design kit that comes
with the NVNA option.
7.6.3 Select PHD (X-params)->Create Single PHD
Component, and select the .mdf file from the
load pull or sweep plan measurement. This will
create a .dsn file.
7.6.4 Open the ADS schematic, and drag and drop the
new .dsn file into the place for the active device.
7.6.5 Click the Simulate icon to start circuit simulation.
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